Change to german language

Switch to german Switch to english

Tuesday, August 6, 2013

*Solved* MS Exchange 2013 : OWA login fails / error message: '.', hexadecimal value 0x00 is an invalid character. row 1, column 1

When running Exchange 2013 it might happen, that Login on Outlook Web App suddenly Fails with error message: '.', hexadecimal value 0x00 is an invalid character. row 1, column 1 Additionally EventID 1309 Source: ASP.NET 4.0.30319.0 is logged in application log. Detailed error message:
[XmlException: '.', hexadecimal value 0x00 is an invalid character. row 1, column 1] System.Xml.XmlTextReaderImpl.Throw(String res, String[] args) +163 System.Xml.XmlTextReaderImpl.ParseRootLevelWhitespace() +7569814 System.Xml.XmlTextReaderImpl.ParseDocumentContent() +62 System.Xml.XmlReader.ReadToFollowing(String name) +112 Microsoft.Exchange.Data.ApplicationLogic.Extension.KillBitHelper.ReadKillBitXmlContent(XmlReader reader, Int32& refreshRate) +185 Microsoft.Exchange.Data.ApplicationLogic.Extension.KillBitHelper.TryReadKillBitFile(Int32& refreshRate, DateTime& lastModifiedTime) +668 Microsoft.Exchange.Data.ApplicationLogic.Extension.KillBitTimer.Start() +193 Microsoft.Exchange.Clients.Owa2.Server.Core.OwaApplication.Initialize() +485 Microsoft.Exchange.Clients.Owa2.Server.Core.BaseApplication.ExecuteApplicationStart(Object sender, EventArgs e) +1319 [HttpException (0x80004005): '.', hexadecimal value 0x00 is an invalid character. row 1, column 1] System.Web.HttpApplicationFactory.EnsureAppStartCalledForIntegratedMode(HttpContext context, HttpApplication app) +12864365 System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers) +175 System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context) +304 System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +404 System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext) +475 [HttpException (0x80004005): '.', hexadecimal value 0x00 is an invalid character. row 1, column 1] System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +12881108 System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +159 System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +12722297
On the same time ECP and Mailflow are running without issues.

Solution:

On the Exchange Server (CAS) go to directory \Exchange\ClientAccess\owa\15.0.516.30\owa2\ext\killbit

and verify, if the file killbit.xml is present and delete or cut it.

Afterwards run iisreset.

3 comments:

  1. Wish this had worked for me. I tried it out, but the same error persists and cant get beyond login screen for OWA and ECP.

    ReplyDelete
  2. It works for me, Excelent, congrats!!!. I had this issue and the same problem, but in this case, only OWA fails not ECP.

    ReplyDelete
  3. Mazenet Technologies is a comprehensive IT service provider for enterprise security solutions, offering a full range of Networking to support business infrastructure. Our 18+ years of expertise in storage optimization, cloud migration, and managed security services have aided the timely delivery of solutions by enhancing operational excellence in clients’ business. IT Infrastructure Service Provider | Managed Infrastructure Service Provider, IT Infrastructure Service | Infrastructure management Service & Network Consulting Service | IT Infrastructure Consulting | Network Consulting Get quote now or contact us : 7397723052.

    ReplyDelete